EasySpec

Version 1.10

Introduction

EasySpec (ES) was created in to make analysis as astronomy spectra fun and easy,
hence the name. There are several programs already available, but as a beginner, |
found them to be either too sophisticated or too simple but with a less than satisfying
user interface. My goal was to automate basic functions and really streamline the
process of going from a raw spectra to a possible identification. | also wanted to make it
easy to document, save and share your findings. | think ES does all this nicely.

B tssySpec - version 1.0 = | B | |

File Edit Help

5095A Mar 25, 2020 Sirius - AOv
06828
Date David Scott - Evo 8 + 0.63FR - S5A-100 - 178MM - 3.68 A/px

Object

7000
Spectral type Mcalibrated

I:‘Re Ference
e0oo
Calibration 5000
Wavelength

4000 W 4

4861 - H beta -

i 3000
References , \1\‘
2000 1\(
1000 / \t,\\\

0 1000 2000 3000 4000 5000 €000 7000 6000 5000 10000
Wavelength (&)

Elements/Lines

=[] Hydrogen balmer
[]8563 - H alpha
[7] 4861 - H beta
[[14341 - H gamma
[7] 4102 - H delta
[]3970 - H epsilen

[C1 Type O (early) - M Show R curve B Show calibrated spectrum  Bll[Show corrected spectrum| B Show sample lines B Show legend

m

WSYNOLOGYWA pectratRaw data\Siri WithDisplayStretch.png

Cloudy Nights member: descottl12
May 10, 2024

EasySpec 1.10 1



Table of Contents

Installation
The main screen

The Study Area

The Calibration Area

The Reference Area

The Graph Area

The Colorized Spectral Band

The Raw Spectrum Area
Loading a raw spectrum
Calibration

Two point calibration

One point calibration

Non-linear calibration
References
Instrument Response Curves
Calculating Doppler shifts
Stellar properties calculator
Miscellaneous

Saving your data

Screen capture

Smooth curve

Flatten curves

EasySpec 1.10

a1

c O

10
13
15
16
17

17
17
17
17



Online reference
Preferences

General

Appearance

Gear
Appendices

Troubleshooting

The configuration file

The Wavelengths.xml file

Version history

EasySpec 1.10

17
18
18
18
19
21
21
21
22

23



Installation

There is no installation required. Simply drag and drop the ES folder to a convenient
place (such as your Desktop) and run the EasySpec.exe program file. You may wish
to create a shortcut to this file in your Task Bar for easy access.

The application is a Windows program and it has been tested on Windows 7 and 10. In
addition to the program file, there is a configuration file, EasySpec. ini, that may
contain various settings. You should not need to edit this file directly but its contents
are described in the Appendix.

The main screen
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The main screen is composed of several different areas:

The Study Area

1. This is where you can specify the name of your object of interest as well as the
equipment that you used to capture the spectrum (optics, camera and spectroscope).
The Date field will be automatically pulled from the raw spectrum image file when it is
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loaded but you can override the date if needed. The choices for the optics, scope and
camera are configured in Preferences. There is a Notes field that can be used to
display a short annotation about the exposure, etc. It is displayed just above the Graph
area.

The Calibration Area
2. This is where you specify the wavelengths of your calibration points and calibrate
your spectrum.

The Reference Area

3. This is where you can overlay a reference spectrum from the Pickle library and/or
various wavelengths of interest. For example, you could overlay an AOv spectrum and
one or more of the Balmer lines.

The Graph Area

4. This is where your processed spectrum will be displayed. It can display one or more
of the following: your raw spectrum, the calibrated spectrum, a spectrum corrected for
your instrument response, the instrument response itself, as well as a legend, a

Show IR curve B Show calibrated spectrum Show corrected spectrum Show sample lines B Show legend

reference spectrum and any number of reference lines. Some of these choices can be
selected by checking the appropriate checkboxes below the graph. The graph can be
panned around by left-clicking and dragging the mouse and you can zoom in or out with
the mouse wheel or by pressing the + and - keys, respectively. Double-clicking will
automatically set the zoom to 100% and center the graph.

The Colorized Spectral Band
5. The visible part of the captured spectrum is displayed here. Absorptions are shown
as darker vertical lines and emissions as lighter vertical lines.

The Raw Spectrum Area
6. This is where the raw spectrum data file is displayed. Controls in this area allow you
to rotate the image and to specify a narrow band area to sample the spectrum.

Loadlng a raw spectrum

To load a spectrum, simply drag and drop the raw image file onto the Raw Spectrum
Area. The date of the spectrum file will be used to fill in the date in The Study Area. If
this date is not correct, you can edit the date directly by typing in the field or by double-
clicking in the field to bring up a calendar date picker.

Images should be captured in a lossless format in order to maintain the most

information. This includes lossless png and FITS files. In addition, you can load a SER
movie file (currently only 16-bit monochrome files are supported).
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Raw spectra files should be captured so that the first order spot is on the left (gold
arrow) The spectrum can be panned around by left-clicking and dragging the mouse.
The spectrum can be zoomed by rolling the mouse wheel or by pressing the + and -
keys, respectively. Double-clicking will automatically set the zoom to 100% and center

/

Down | W Subtract BG noise

the image.

Once you get the spectrum centered and zoomed appropriately, you can rotate it
clockwise or counter clockwise as needed by pressing the CW and CCW buttons,
respectively. The image will rotate 1 degree or 10 degrees if you hold the Shift key
when pressing the buttons.

The sampling area is identified by the two parallel red lines. You can move the sampling
area up or down by pressing the Up and Down buttons, respectively. The image will
move 1 pixel or 10 pixels if you hold down the Shift key when pressing the buttons. In
addition you can move the sample area to a specific point by Shift left-clicking on any
spot in the image. When the spectrum image window has the mouse focus, you can
also use the up and down arrow keys to move up or down by 1 pixel. You can adjust the
height of the sampling area by pressing the Squeeze and Spread buttons. The
sampling area will change by 1 pixel or 10 pixels if you hold down the Shift key when
pressing the buttons.

Note: It is best to capture your spectra fﬁ b |Be IF - 4685
with the spectrum as close to [l '\1 He II - pell o
horizontal as possible. This is o % = o e S
because any rotation can and will | [H gampa -)4341
introduce some artifacts such as ﬂl S :“.;igé -
jagged spikes (as shown below - red [ r|"““uI A rai
arrows) that can substantially alter f '];\L /
your results. A rotation of a degree or hrf‘u, //
two is not bad but anything larger 1} M
should be avoided if possible. - U 1
’ﬂ""'L]
lM"W
‘u"-a"lh
h'*llw
1"1“‘,“”[
Ty

EasySpec 1.10 6



Check the Subtract BG noise checkbox to automatically remove any background noise
detected in the sampling area. This may or may not improve the resulting spectrum
(depending on your data).

You can display or hide the sample area lines by checking the Show sample lines
checkbox as needed.

As you move or otherwise alter the sampling area, the spectrum will be displayed and
updated in The Graph Area.

If you have loaded a SER data file,
then the Prev and Next buttons in
the lower-right corner will be
enabled. These allow you to step
through each frame in the file in
order to find the best frame. When N  sbtract 56 noise
the spectrum image viewer has the —————

mouse focus, you can use the left

and right arrow keys to change the current frame.
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Calibration

Once you have loaded a raw spectrum and defined your sample area, it is time to
calibrate the spectrum. Calibration can be done in a few ways:

Two point calibration

Right click on a point in The Graph Area and : :
choose Add as first calibration point. The Calibration
pixel value of this point is placed into the first Pixel Wavelength

wavelength field in The Calibration Area.

Choose the wavelength that is associated
with this point. Right click on a second point in

The Graph Area and choose Add as second 1469 4861 - H beta v
calibration point. The pixel value of this : :
point is placed into the second wavelength Dispersion D

field in The Calibration Area. Choose the
wavelength that is associated with this

second point.

You can choose any identifiable wavelengths but it is customary to use the zero order
peak and one of the H Balmer absorptions, if visible. Note: the choices for wavelengths
to choose from in the lists can be configured. Click here for more information.

Once you have defined both points, press the Calibrate button. The Dispersion will be
calculated and displayed and your calibrated curve will be displayed in The Graph
Area.

One point calibration

If you already know the dispersion of your 2 2
system, you can use a one point calibration. Calibration
Right click on a point in The Graph Area and Pixel Wavelength

choose Add as first calibration point. The

pixel value of this point is placed into the first
wavelength field in The Calibration Area. You

can choose any identifiable wavelengths but it |:|
is usually easiest to use the zero order peak. _ _ —
Enter your Dispersion, press the Calibrate Dispersion | 3.65

button and your calibrated curve will be
displayed in The Graph Area. Reset

You can undo the calibration and start over by pressing the Reset button. Also, if you
didn’t click exactly on the right spot when adding your calibration points and your
calibrated curve isn’t matching your reference lines (see below) perfectly, you can tweak
the calibration by editing the pixel values in The Calibration Area and then press
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Calibrate again. For example, in the example above, | could change the 49 to 48 or 50
and then press Calibrate.

Non-linear calibration

EasySpec can also calibrate non-linear data files that result from systems such as the
Alpy 600 or even the SA-100 when used in conjunction with a prism. In these cases, a
simple linear relationship between horizontal pixels and the wavelength does not exist.

To _Start_ a non-linear Mon-linear calibration &J
calibration, press the

Calibrate button while Pixel Wavelength Residual
holding the Shift key

down. The Non-linear 151 0 - Zero order -0.564415 |E
calibration window will 1324 4341 - H gamma 14228522 -
open. On the spectrum 1476 4861 - H beta -16.687365
graph, right click on 1944 6563 - H alpha 3.023258
identifiable features and

choose Add calibration — e

L I

.y

point. Repeat this for
multiple pixel values Order
and the pixel values will

Pixel column. The pixel :

values will be
automatically placed in
the first blank field. If
you preselect a pixel
edit field, then the next click will fill that space. For each pixel value, click in the
Wavelength cell and choose a wavelength from this list or enter a value.

Once you have your pixel wavelengths defined, choose an order from the Order list and
press Fit. A polynomial will be generated to fit the
data and the errors for each point will be displayed | Note that you must have one

in the Residual column. The actual coefficients of | more point than the order. So, a
the polynomial will be displayed as well. Press the second order fit would require 3
Calibrate button and display some reference lines | points.

on the spectrum to see how well the fit is.

If the residuals are too high or the fit on the graph is not good, you can add more data
points or change the Order. For best results, the residuals should be all very close to
zero. After making a change, you can press Fit and Calibrate again to see how it looks.
Press the Reset button to clear the calibration and start over. If you press the SHIFT
button while pressing Reset, then the pixel values, wavelengths and residuals will also
be cleared. Note that higher order polynomials can generally fit more complicated data
but you will need more data points.
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Once your calibration looks good, just close the window by pressing the X button in the
upper-right corner. The polynomial will be remembered and will be re-displayed in the
Non-linear calibration window the next time you open it. If you happen to be working
with the same data file, you don’t have to re-select points and fit the data. You can
simply press Calibrate to calibrate the spectrum. If the data file is different, then you will
need to redo the calibration process.

Once a spectrum has been calibrated, the x-axis will change from pixels to Angstroms.
Since the zero-order peak and the blank area between the zero-order peak and the
actual spectrum data are no longer needed, you can limit the spectrum’s display by
right-clicking on it an choosing Set the lefthand wavelength and Set the righthand
wavelength. These will limit the display but you can always right-click and choose
Reset wavelength range to view the entire spectrum.

References

Once you have calibrated your spectrum, you
can overlay reference spectra and/or reference References
lines. Reference lines are arranged in groups

such as Hydrogen Balmer or Type O. You can
select an entire group or select only certain =[] Hydrogen balmer .

lines with a group. 6563 - H alpha

Most reference lines are a single wavelength, 4861 - H beta
but some (like the Telluric absorptions) are

Elements/Lines =

actually a broader band or range of ] 4341 - H gamma
wavelengths. ] 4102 - H delta
ri0 : Fioo 713970 - H epsilen
e e Frajunhofer & 02 : 7594 =+ I:' TFF'E 0 I:EElr|],f:| -
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Note that you can configure the groups and
individual lines that are in this list (see

Appendix). ¥ § beta : 4861

At the bottom of the reference line list, there is a [\ /\'\/\ /

group called “User defined” and this section
can be populated with any number of reference
lines that are of interest but are not currently in
the built-in reference line library. See Prefere

Your name

Smoothing window (pixels)

Flattening window (pixels)

Background level removal fraction (%) D

instructions on adding reference lines.

‘nces for

Reference wavelengths can be displayed as above with a vertical line. You can also
mark them with a small triangular symbol as shown to the right. The actual data and the
shape of the curve determine which looks better. This option can be selected on the
Appearance tab in Preferences.
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You can also display an entire reference spectrum from the Pickle library by checking
the Overlay reference checkbox and selecting a spectrum. By pressing the up or down
arrow keys, you can display each reference until you find the best match.

To jump to the start of a main spectral type category, just press the appropriate
OBAFGKM button.
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Instrument Response Curves

To create an instrument response (IR) curve, load and calibrate a spectrum. Then

overlay a corresponding reference spectrum. Choose Tools » Instrument response »
Create from the main menu. A popup window will appear. Give your IR curve a name. It
is good idea to include information like the name of the source object, the spectral type,
the camera, and/or the date. Now you will select points on the graph to specify a range
of wavelengths to include in the IR curve. This is important as your sensor likely does

( | = |

Create instrument response curve

=
]

\

) 3000 4000 5000 6000 7000 8000 9000
Wavelength (A)

MH—»

not have the same sensitivity to a wide range of wavelengths as the reference. So we
want to limit it in order to make a useful IR curve. Basically, only include areas on the
curve that show a meaningful response above the baseline. The example shows two
red arrows that specify a start and stop wavelength. Right click on a spot and choose
Set start/stop wavelength for IR response curve from the popup menu. Do this twice,
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once for the start and once for the stop wavelength. You can reselect points if you are
not happy with your choices. Press Ok to continue and our IR curve will be saved. You
will be prompted to apply it now. You can press Yes to apply it now or No and load it
later.

To load and apply an IR curve, choose Tools » Instrument response » Load from the
main menu. A list will appear and you can choose a curve. Be sure to apply a curve

Calibrnated

Corregted

5000

B | ﬂ[\

MN\

N
=\

1000 T~ .
0 1000 2000 3000 4000 5000 e000 7000 8000 9000
Wavelength (L4)

|
—

M

that was created for the current sensor/optics. This is a good reason why it is important
to include that information in the curve’s name when you create them. Depending on
how you have your display checkboxes checked, you could see a calibrated curve, a
corrected curve and possibly the IR curve. The IR curve does not use the Intensity
values for the Y-axis as the other curves do. In reality the IR curve is really just a ratio
and it is normalized so 1000 on the Y-axis equals a ratio of 1.0. The corrected curve is
simply the calibrated curve divided by the IR curve. So the curves will be equal when
the IR curve is 1000 (ratio of 1.0), the corrected curve will be below the calibrated curve
when the IR curve > 1000 and the corrected curve will be above the calibrated curve
when the IR curve < 1000.
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Calculating Doppler shifts

To calculate a Doppler shift, load and calibrate a spectrum. Choose Tools » Calculate
Doppler shift from the main menu. A popup window will appear. Identify a feature that

appears to be shifted. Enter the shifted wavelength and the corresponding rest
wavelength. Alternately, you can right

click on the calibrated spectrum and

choose Set the shifted wavelength...

or Set the rest wavelength... and

these values will be auto-filled into the
data entry form. The Doppler shift, the

z value, the velocity and the distance
will be calculated.

You can then plot this shift on the
calibrated spectrum by providing a
label and pressing the Add button.
Any number of doppler shifts can be
plotted and you can remove them by
pressing the Clear all plotted shifts
link.

Ha +623|
LY
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Velocity (km/s) 28444
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Stellar properties )

calculator Stellar properties calculator u

Choose Tools » Stellar properties
calculator from the main menu. The Spectral type A3v
calculator window will appear. You
can select a spectral type and enter :

an apparent magnitude and this tool Apparent magnitude
will calculate the temperature,
absolute magnitude, luminosity,
distance and radius. Note that the

calculations are only approximations Temperature (K) 8750
but they should be relatively

accurate. Absolute magnitude 20

Luminosity 14

Distance (parsecs) 29.50

Radius
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Miscellaneous

Saving your data

You can save your spectrum data to a .dat file format by choosing File » Save from the
main menu. You will be prompted for a folder to save the data into. The text in the
Object field (in The Study Area) is used to name the file so you must enter an object
name first. The raw and calibrated data will be saved. For example:

c:\my folder\vega raw.dat
c:\my folder\vega calibrated.dat

Screen capture
You can capture your current screen (both the graph and the raw spectrum) by

choosing Edit » Screen capture from the main menu. The image will be saved into the
Windows clipboard and you can then paste into another application and save it as a file.

Smooth curve

You can smooth the raw spectrum graph (if not calibrated yet) or the calibrated
spectrum graph by choosing Edit » Smooth curve from the main menu. Note: to un-
smooth the curve, simply re-calibrate the curve.

Flatten curves

You can smooth the calibrated spectrum graphs and a reference spectrum (if displayed)
by choosing Edit » Flatten curves from the main menu. This will attempt to normalize
the baseline and produce a “flat” curve so it easier to compare absorptions and
emissions. Note: to un-flatten the curve, simply re-calibrate the curve.

Online reference

You can automatically open a online spectral types reference by choosing Help »
Online reference from the main menu. By default, this goes to very helpful Wikipedia
page but the URL can be configured in the configuration file (see Appendix).
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Preferences

Choose File » Preferences from the main menu to specify the choices you have the
lists for you gear, set colors, and some other the settings. There are a few tabs.

General

The General tab allows you to specify your name as it will appear on the graph and
when you take screenshots.

The size of the data windows used when smoothing and flattening your curves can
also be set. A large window is more aggressive and can remove wanted detail but a
small window may not have enough effect to work well. For smoothing, you should use
a small window (around 2 or 5, for example). For flattening you need to use a much
larger window (such as 200 or so0). You may need to experiment to find values that work
well with your data.

The Background level removal fraction is the amount of the background noise level
that is removed in order to move your raw spectrum down towards the zero baseline.
This number should typically be around 75 to 85 for good results but this will depend on
your actual data.

General Appearance Gear Wavelengths

Your name

Smoothing window (pixels)

Flattening window (pixels)

Background level removal fraction (35)

A

Press Apply to save your changes. You do not need to close the Preferences window
for your changes to have an effect.

Appearance

The Appearance tab allow you choose colors for the various parts of the graph, the line

width (for the raw and calibrated spectrum only) and you can choose how to annotate
wavelengths of interest (with either a vertical line or an arrow symbol). Press Apply to

EasySpec 1.10 18



save your changes. You do not need to close the Preferences window for your

Preferences

=

General || Appearance ;| Gear

Spectrum line thickness . Margin color

. Graph background color

Reference line display Axes

Vertical line - Raw spectrum

Calibrated spectrum

Reference spectra
Reference lines
Instrument response
Corrected spectrum

Teaxt

[ Apply ]

changes to have an effect.

Gear

The Gear tab allows you to specify your Optics, Cameras and Spectroscopes. For
each, press the + and - buttons to add and remove choices, respectively. Double-click
on a choice to edit it. Press Apply to save your changes. You will not need to close the
Preferences window and restart the program before your changes will take effect.

EasySpec 1.10
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Preferences

Optics/telescopes

Evo &
Evo & + 0.63FF

General | Appearance

Cameras

178MM

Spectroscopes

5A-100

Wavelengths

The Wavelengths tab allows you to specify user-defined reference lines that can be
overlaid over your calibrated spectra. Press the + and - button to add and remove

reference lines.
Double-click on an
entry to edit it. Press
Apply to save your
changes. You will not
need to close the
Preferences window
and restart the
program before your
changes will take
effect.

To add or edit an
entry, enter a text
Label and a

-

Preferences [

’ General l Appearance I Gear | Wavelengths

Wavelength
Label

Wavelength (A)

To (A, for bands)

wavelength. If the reference line is actual a wider band, the also enter a wavelength in

the To field.

EasySpec 1.10
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Appendices
Troubleshooting

Q: Why do a get an error message about a dll file missing when trying to start the
application?

A: As with all Windows programs, this program requires various helper .dll files. The
necessary ones should be included in the installation folder. However, if you receive a
message when trying to start the application about a dll file that is missing, please let
me know and | will fix the omission.

Q: Why does my calibrated curve not appear when | press Calibrate?
A: Make sure the Show calibrated spectrum checkbox is checked. See The Graph
Area.

The configuration file

EasySpec.ini is the configuration file that lives in the same folder as the program
file. It is a standard Windows .ini file with [SECTIONS] in square brackets and individual
NAME=VALUE settings in each section. Comments lines begin with a semicolon
symbol.

[GENERAL]

; The last used choices for your equipment are saved here
defaultOptics=Evo 8 + 0.63FR

defaultCamera=178MM

defaultScope=SA-100

; the last calculated dispersion is saved here
dispersion=3.65

; this is a scale factor used to make the IR curve viewable on

; the graphs. This means that a IR curve value of 1.0 is graphed
; as 1000 on the intensity scale

IRCurveScaleFactor=1000

; your name as configured in the Preferences
yourName=David Scott

; the web page used by Help > Online Reference
ReferenceURL=https://en.wikipedia.org/wiki/Stellar classification

; professionally recorded spectra capture data over a much wider
; wavelength range which go above and below what what a typical
; amateur setup can measure. These settings allow

; us to clip of parts of the spectrum to a more realistic range.
referenceSpectrumLowerCutoff=3500
referenceSpectrumUpperCutoff=9000
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; The data window size used when smoothing curves.
smoothingWindowSize=10

; the data window size used when flattening curves.
flatteningWindowSize=50

[DISPLAY]

; the various colors are save here. The format is:
; r g b alpha

; the alpha value is currently ignored
marginColor=255 255 255 255
graphBackgroundColor=229 229 229 255

axisColor=50 50 50 255

rawSpectrumColor=128 0 64 255
calibratedSpectrumColor=0 0 255 255
referenceSpectrumColor=255 128 0 255
referencelineColor=255 128 0 255
instrumentResponseColor=100 100 100 255
textColor=0 0 0 255

correctedSpectrumColor=0 200 0 255

; the line width - currently only used for the RAW spectrum
spectrumLineWidth=1

[COLOR_BAND]

; these settings control how the colorized spectrum band is
generated from the raw data.

; this can affect how well absorption and emission lines

; are detected

smoothingWindowSize=50

; decreasing this tends to make the absorptions darker and the
emissions lighther.

yMaxReduction=0.7

The Wavelengths.xml file

This file determines what reference lines and groups are displayed in the The
Reference Area. It is stored in the Resources folder inside the main installation folder.
It is a standard xml file and it can be edited as needed but please only use Notepad as
other editors can over-complicate the file and make it unusable. The format is as
follows:

<wavelengths>

<group name="Hydrogen balmer">
<wavelength name="H alpha" value="6563" calibrate="yes"/>
<wavelength name="H beta" value="4861" calibrate="yes"/>
</group>
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<group name="Type O (early)">
<wavelength name="He I" value="4471" />
<wavelength name="He II" value="4686" />
<wavelength name="He II" value="5411" />
</group>

<group name="Type G">

<wavelength name="H" value="3968" />

<wavelength name="K" value="3934" />

<wavelength name="Ca I" value="4227"/>

<wavelength name="G band" value="4300" to="4313" />
</group>
</wavelengths>

You can have any number of <group> tags and each <group> can have one or more
<wavelengths> inside it. The values are in Angstroms. The calibrate="yes”
attribute specifies that this entry should also be used in the wavelength lists in The
Calibration Area.

Most <wavelength> entries have a name and a value for the wavelength. You can
also define a band of wavelengths as in the “G band” entry above. In these cases, you
provide a value and a second wavelength with the “to” tag.

Version history

Version 1.0
Initial release

Version 1.1

1. Bug fix - The colors would sometimes make the graph lines patrtially transparent.

2. Bug fix - Reference spectrum F2iv was incorrectly labeled as FO2iv.

3. Bug fix - The spectral type edit control was ignored so the user couldn't manually
enter a spectral class.

Version 1.2

1. Updated wavelengths.xml to include carbon stars.

2. Can now display reference bands, not just lines.

3. Updated Wavelengths.xml to display the G band as a band and added the Telluric
absorption bands.

Version 1.3

1. Updated wavelengths.xml to include Fe Il class novas, S-class stars, more WR
emissions and SN Type la.

Reference lines can now be identified with vertical lines or arrow symbols.
Added the Notes field.

Can now load an external .dat file as a reference curve.

Subtract background noise was not subtracting the correct value.

Bug fix - calibration failed if the first calibration point was not the zero order peak.

oOghwWN
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Version 1.4

1. Added the Stellar Properties Calculator

2. Bug fix - The tool tip for Dispersion was attached to the first pixel entry field.
3. Added the ability to do non-linear calibration

Version 1.5
1. Added the ability to define user-defined reference lines.

Version 1.6

1. Any wavelength value can be entered now when doing a non-linear calibration.
Before, the user had to pick from a list of predefined wavelengths.

2. The spectral types list was not sorted properly.

Version 1.7

1. Changes to the Smoothing preference are automatically reflected in the display
graph.

2. The App would crash if a user-defined wavelength label was too long or if it contained
a double quote character.

3. Fixed incorrect log file message about not being able to open the Wavelngths.xml file.

Version 1.8
1. Added support for loading SER video files.
2. Added support for 16-bit monochrome FITS files

Version 1.9

1. Could not set the starting wavelength when creating an IR curve.

2. When doing a non-linear calibration, the clicked pixel value will go to the selected
cell first (if one is selected).

3. Don't display erroneous 0.0 A/pix dispersion when doing a non-linear calibration.

4. Included more reference wavelengths in the choose list when doing a non-linear
calibration.

5. Truncate reference spectrum to between 3500 and 9000 Angstroms. This is
configurable in the .ini file.

6. The Reset button on the Non-linear calibration tool can optionally clear the residual
calculations table or leave all values to be edited.

Version 1.10

1. Can now choose the wavelength start and end values for display of calibrated data.

2. Recompiled with VS 2022. May need to install the latest C runtime in order to run
app.

3. Added the ability to plot doppler shifts on a calibrated spectrum.

4. Fixed background noise subtraction and made the amount of subtraction
configurable.
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