EasySpec

Version 1.8

Introduction

EasySpec (ES) was created in to make analysis as astronomy spectra fun and easy,
hence the name. There are several programs already available, but as a beginner, |
found them to be either too sophisticated or too simple but with a less than satisfying
user interface. My goal was to automate basic functions and really streamline the
process of going from a raw spectra to a possible identification. | also wanted to make it
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easy to document, save and share your findings. | think ES does all this nicely.

Cloudy Nights member: descottl12
November 10, 2023
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Installation

There is no installation required. Simply drag and drop the ES folder to a convenient
place (such as your Desktop) and run the EasySpec.exe program file. You may wish
to create a shortcut to this file in your Task Bar for easy access.

The application is a Windows program and it has been tested on Windows 7 and 10. In
addition to the program file, there is a configuration file, EasySpec. ini, that may
contain various settings. You should not need to edit this file directly but its contents
are described in the Appendix.

The main screen

The main screen is composed of several different areas:
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The Study Area

1. This is where you can specify the name of your object of interest as well as the
equipment that you used to capture the spectrum (optics, camera and spectroscope).
The Date field will be automatically pulled from the raw spectrum image file when it is
loaded but you can override the date if needed. The choices for the optics, scope and
camera are configured in Preferences. There is a Notes field that can be used to
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display a short annotation about the exposure, etc. It is displayed just above the Graph
area.

The Calibration Area
2. This is where you specify the wavelengths of your calibration points and calibrate
your spectrum.

The Reference Area

3. This is where you can overlay a reference spectrum from the Pickle library and/or
various wavelengths of interest. For example, you could overlay an AOv spectrum and
one or more of the Balmer lines.

The Graph Area

4. This is where your processed spectrum will be displayed. It can display one or more
of the following: your raw spectrum, the calibrated spectrum, a spectrum corrected for
your instrument response, the instrument response itself, as well as a legend, a

Show IR curve K Show calibrated spectrum [l Show corrected spectrum B Show sample lines Kl Show legend

reference spectrum and any number of reference lines. Some of these choices can be
selected by checking the appropriate checkboxes below the graph. The graph can be
panned around by left-clicking and dragging the mouse and you can zoom in or out with
the mouse wheel or by pressing the + and - keys, respectively. Double-clicking will
automatically set the zoom to 100% and center the graph.

The Raw Spectrum Area
5. This is where the raw spectrum data file is displayed. Controls in this area allow you
to rotate the image and to specify a narrow band area to sample the spectrum.

Loadlng a raw spectrum

To load a spectrum, simply drag and drop the raw image file onto the Raw Spectrum
Area. The date of the spectrum file will be used to fill in the date in The Study Area. If
this date is not correct, you can edit the date directly by typing in the field or by double-
clicking in the field to bring up a calendar date picker.

Images should be captured in a lossless format in order to maintain the most
information. This includes lossless png and FITS files. In addition, you can load a SER
movie file (currently only 16-bit monochrome files are supported).

Raw spectra files should be captured so that the first order spot is on the left (gold
arrow) The spectrum can be panned around by left-clicking and dragging the mouse.
The spectrum can be zoomed by rolling the mouse wheel or by pressing the + and -
keys, respectively. Double-clicking will automatically set the zoom to 100% and center
the image.
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Down | W Subtract BG noise

Once you get the spectrum centered and zoomed appropriately, you can rotate it
clockwise or counter clockwise as needed by pressing the CW and CCW buttons,
respectively. The image will rotate 1 degree or 10 degrees if you hold the Shift key
when pressing the buttons.

The sampling area is identified by the two parallel red lines. You can move the sampling
area up or down by pressing the Up and

Down buttons, respectively. The image will Note: It is best to capture your spectra
move 1 pixel or 10 pixels if you hold down the  |wjth the spectrum as close to

Shift key when pressing the buttons. In horizontal as possib|e_ This is

addition you can move the sample area to a because any rotation can and will

SpeCiﬁC pOint by Shift |eft-C|iCking on any SpOt introduce some artifacts such as
in the image. You can adeSt the hEIght Of the Jagged Spikes (as Shown beIOW - red

sampling area by pressing the Squeeze and arrows) that can substantially alter
Spread buttons. The sampling area will your results. A rotation of a degree or
change by 1 pixel or 10 pixels if you hold down |two is not bad but anything larger

the Shift key when pressing the buttons. should be avoided if possible.

Check the Subtract BG noise checkbox to
automatically remove any background noise
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detected in the sampling area. This may or may not improve the resulting spectrum

(depending on your data).

You can display or hide the sample area lines by checking the Show sample lines

checkbox as needed.

As you move or otherwise alter the sampling area, the spectrum will be displayed and

updated in The Graph Area.

If you have loaded a SER data file,
then the Prev and Next buttons in
the lower-right corner will be
enabled. These allow you step
through each frame in the file in
order to find the best frame.
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Calibration
Once you have loaded a raw spectrum and defined your sample area, it is time to
calibrate the spectrum. Calibration can be done in two ways:

Two point calibration

Right click on a point in The Graph Area and : =
choose Add as first calibration point. The Ca“bratlon
pixel value of this point is placed into the first Pixel Wavelength

wavelength field in The Calibration Area.

Choose the wavelength that is associated
with this point. Right click on a second point in

The Graph Area and choose Add as second 1469 4861 - H beta ke
calibration point. The pixel value of this

point is placed into the second wavelength Dispersion I:I
field in The Calibration Area. Choose the

wavelength that is associated with this ‘ Calibrate ] [ Reset
second point.

You can choose any identifiable wavelengths but it is customary to use the zero order
peak and one of the H Balmer absorptions, if visible. Note: the choices for wavelengths
to choose from in the lists can be configured. Click here for more information.

Once you have defined both points, press the Calibrate button. The Dispersion will be
calculated and displayed and your calibrated curve will be displayed in The Graph
Area.

One point calibration

If you already know the dispersion of your 2 2
system, you can use a one point calibration. Calibration
Right click on a point in The Graph Area and Pixel Wavelength

choose Add as first calibration point. The

pixel value of this point is placed into the first
wavelength field in The Calibration Area. You

can choose any identifiable wavelengths but it |:| 4861 - H beta hd
is usually easiest to use the zero order peak. _ _ -
Enter your Dispersion, press the Calibrate Dispersion

button and your calibrated curve will be .
Calibrate | Reset

displayed in The Graph Area.

You can undo the calibration and start over by pressing the Reset button. Also, if you
didn’t click exactly on the right spot when adding your calibration points and your
calibrated curve isn’t matching your reference lines (see below) perfectly, you can tweak
the calibration by editing the pixel values in The Calibration Area and then press
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Calibrate again. For example, in the example above, | could change the 49 to 48 or 50
and then press Calibrate.

Non-linear calibration

EasySpec can also calibrate non-linear data files that result from systems such as the
Alpy 600 or even the SA-100 when used in conjunction with a prism. In these cases, a
simple linear relationship between horizontal pixels and the wavelength does not exist.

To _Start_ a non-linear Mon-linear calibration &J
calibration, press the

Calibrate button while Pixel Wavelength Residual
holding the Shift key

down. The Non-linear 151 0 - Zero order -0.564415 |E
calibration window will 1324 4341 - H gamma 14228522 -
open. On the spectrum 1476 4861 - H beta -16.687365
graph, right click on a 1944 6563 - H alpha 3.023258
identifiable features and

choose Add calibration — e

L I

.y

point. Repeat this for
multiple pixel values Order
and the pixel values will

Pixel column. For each ;

pixel value, click in the
Wavelength cell and
choose a wavelength
from this list or enter a
value.

Once you have your pixel wavelengths defined, choose an order from the Order list and
press Fit. A polynomial will be generated to fit the data and the errors for each point will
be displayed in the Residual column. The actual coefficients of the polynomial will be
displayed as well. Press the Calibrate button and display some reference lines on the
spectrum to see how well the fit is.

If the residuals are too high or the fit on the graph is not good, you can add more data
points or change the Order. After making a change, you can press Fit and Calibrate
again to see how it looks. Press the Reset button to clear the calibration and start from
scratch. Note that higher order polynomials can generally fit more complicated data but
you will need more data points. As a rule you need at least one more data point than the
order. So a second order polynomial needs at least 3 points. In reality adding more
points will help get a better fit.

Once your calibration looks good, just close the window by pressing the X button in the

upper-right corner. The polynomial will be remembered and will be re-displayed in the
Non-linear calibration window the next time you open it. If you happen to be working
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with the same data file, you don’t have to re-select points and fit the data. You can
simply press Calibrate to calibrate the spectrum. If the data file is different, then you will

need to redo the calibration process.

References

Once you have calibrated your spectrum, you
can overlay reference spectra and/or reference
lines. Reference lines are arranged in groups
such as Hydrogen Balmer or Type O. You can
select an entire group or select only certain
lines with a group.

Most reference lines are a single wavelength,
but some (like the Telluric absorptions) are
actually a broader band or range of
wavelengths.

TiQ : E1930

TiO |: 5480
Fraunhofer & 02 : 7594
HPO |: TleB-7394

T
N

Note that you can configure the groups and
individual

[

References

Elerments/Lines .

= Hydrogen balmer
¥ 6563 - H alpha

4341 - Hgamma
4102 - H delta

2970 - H epsilon

m

& Type O (early) -

4 1 F

pooEEnm

lines that
are in this
list (see

Appendix).
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At the bottom of the reference line list, there is a group called “User defined” and this
section can be populated with any number of reference lines that are of interest but are
not currently in the built-in reference line library. See Preferences for instructions on
adding reference lines.

Reference wavelengths can be displayed as above with a vertical line. You can also
mark them with a small triangular symbol as shown to the right. The actual data and the
shape of the curve determine which looks better. This option can be selected on the
Appearance tab in Preferences.

You can also display an entire reference spectrum from the Pickle library by checking
the Overlay reference checkbox and selecting a spectrum. By pressing the up or down
arrow keys, you can display each reference until you find the best match.

To jump to the start of a main spectral type category, just press the appropriate
OBAFGKM button.
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Instrument Response Curves

To create an instrument response (IR) curve, load and calibrate a spectrum. Then

overlay a corresponding reference spectrum. Choose Tools » Instrument response »
Create from the main menu. A popup window will appear. Give your IR curve a name. It
is good idea to include information like the name of the source object, the spectral type,
the camera, and/or the date. Now you will select points on the graph to specify a range
of wavelengths to include in the IR curve. This is important as your sensor likely does

Fa =

Create instrument response curve

Start wavelength -
[ Ll S5top wavelength -

o | o |

) 3000 4000 5000 6000 7000 8000 9000
Wavelength (A)

MH—»

not have the same sensitivity to a wide range of wavelengths as the reference. So we
want to limit it in order to make a useful IR curve. Basically, only include areas on the
curve that show a meaningful response above the baseline. The example shows two
red arrows that specify a start and stop wavelength. Right click on a spot and choose
Set start/stop wavelength for IR response curve from the popup menu. Do this twice,
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once for the start and once for the stop wavelength. You can reselect points if you are
not happy with your choices. Press Ok to continue and our IR curve will be saved. You
will be prompted to apply it now. You can press Yes to apply it now or No and load it
later.

To load and apply an IR curve, choose Tools » Instrument response » Load from the
main menu. A list will appear and you can choose a curve. Be sure to apply a curve

Calibrnated

Corregted

5000

[” M\
o] 1IN
\

|‘ fr-- _‘_H‘Hx

| R

0 1000 2000 3000 4000 5000 €000 7000 8000 S000

Wavelength (L4)

1000

S

that was created for the current sensor/optics. This is a good reason why it is important
to include that information in the curve’s name when you create them. Depending on
how you have your display checkboxes checked, you could see a calibrated curve, a
corrected curve and possibly the IR curve. The IR curve does not use the Intensity
values for the Y-axis as the other curves do. In reality the IR curve is really just a ratio
and it is normalized so 1000 on the Y-axis equals a ratio of 1.0. The corrected curve is
simply the calibrated curve divided by the IR curve. So the curves will be equal when
the IR curve is 1000 (ratio of 1.0), the corrected curve will be below the calibrated curve
when the IR curve > 1000 and the corrected curve will be above the calibrated curve
when the IR curve < 1000.
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Calculating Doppler shifts

To calculate a Doppler shift, load and calibrate a spectrum. Choose Tools » Calculate
Doppler shift from the main menu. A popup window will appear. Identify a feature that
appears to be shifted. Enter the

shifted wa\_/elength and the Calculate Doppler shift ﬁ
corresponding rest wavelength.

Alternqtely, you can right click on Shifted wavelength [A)
the calibrated spectrum and

choose Set the shifted
wavelength... or Set the rest
wavelength... and these values
will be auto-filled. The Doppler
shift, the z value, the velocity and
the distance will be calculated.

Rest wavelength (4) 4700
Doppler shift (A)

ra
F

Velocity (km,s) 8031

Distance 110 Mpc or 359 Mly
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Stellar properties )

calculator Stellar properties calculator u

Choose Tools » Stellar properties
calculator from the main menu. The Spectral type A3v
calculator window will appear. You
can select a spectral type and enter :

an apparent magnitude and this tool Apparent magnitude
will calculate the temperature,
absolute magnitude, luminosity,
distance and radius. Note that the

calculations are only approximations Temperature (K) 8750
but they should be relatively

accurate. Absolute magnitude 20

Luminosity 14

Distance (parsecs) 29.50

Radius
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Miscellaneous

Saving your data

You can save your spectrum data to a .dat file format by choosing File » Save from the
main menu. You will be prompted for a folder to save the data into. The text in the
Object field (in The Study Area) is used to name the file so you must enter an object
name first. The raw and calibrated data will be saved. For example:

c:\my folder\vega raw.dat
c:\my folder\vega calibrated.dat

Screen capture
You can capture your current screen (both the graph and the raw spectrum) by

choosing Edit » Screen capture from the main menu. The image will be saved into the
Windows clipboard and you can then paste into another application and save it as a file.

Smooth curve

You can smooth the raw spectrum graph (if not calibrated yet) or the calibrated
spectrum graph by choosing Edit » Smooth curve from the main menu. Note: to un-
smooth the curve, simply re-calibrate the curve.

Flatten curves

You can smooth the calibrated spectrum graphs and a reference spectrum (if displayed)
by choosing Edit » Flatten curves from the main menu. This will attempt to normalize
the baseline and produce a “flat” curve so it easier to compare absorptions and
emissions. Note: to un-flatten the curve, simply re-calibrate the curve.

Online reference

You can automatically open a online spectral types reference by choosing Help »
Online reference from the main menu. By default, this goes to very helpful Wikipedia
page but the URL can be configured in the configuration file (see Appendix).
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Preferences

Choose File » Preferences from the main menu to specify the choices you have the
lists for you gear, set colors, and some other the settings. There are a few tabs.

General

The General tab allows you to specify your name as it will appear on the graph and
when you take screenshots.

The size of the data windows used when smoothing and flattening your curves can also
be set. A large window is more aggressive and can remove wanted detail but a small
window may not have enough effect to work well. For smoothing, you should use a
small window (around 2 or 5, for example). For flattening you need to use a much larger
window ( such as 200 or so0). You may need to experiment to find values that work well
with your data. Press Apply to save your changes. You do not need to close the

Preferences ﬁ

General | Appearance | Gear

Your name David Scott

Smoothing window (pixels) |:|
Flattening window (pixels)

Preferences window for your changes to have an effect.

Appearance

The Appearance tab allow you choose colors for the various parts of the graph, the line
width (for the raw and calibrated spectrum only) and you can choose how to annotate
wavelengths of interest (with either a vertical line or an arrow symbol). Press Apply to
save your changes. You do not need to close the Preferences window for your
changes to have an effect.
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Preferences

Vertical line -

General || Appearance ;| Gear

Spectrum line thickness . Margin color

Reference line display

. Graph background color

Raw spectrum

Calibrated spectrum

Reference spectra
Reference lines
Instrument response

Corrected spectrum

Gear

The Gear tab allows you to specify your Optics, Cameras and Spectroscopes. For
each, press the + and - buttons to add and remove choices, respectively. Double-click
on a choice to edit it. Press Apply to save your changes. You will not need to close the
Preferences window and restart the program before your changes will take effect.

Preferences

=

Optics/telescopes

Evo &
Evo & + 0.63FF

General | Appearance | Gear

Cameras

178MM

Spectroscopes

5A-100
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Wavelengths

The Wavelengths tab allows you to specify user-defined reference lines that can be
overlaid over your calibrated spectra. Press the + and - button to add and remove

reference lines.
Double-click on an
entry to edit it. Press
Apply to save your
changes. You will not
need to close the
Preferences window
and restart the
program before your
changes will take
effect.

To add or edit an
entry, enter a text
Label and a

-

.
Preferences =]

’ General I Appearance I Gear | Wavelengths
NI : 4641

Wavelength

Label

Wavelength (A)

To (A, for bands)

wavelength. If the reference line is actual a wider band, the also enter a wavelength in

the To field.
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Appendices
Troubleshooting

Q: Why do a get an error message about a dll file missing when trying to start the
application?

A: As with all Windows programs, this program requires various helper .dll files. The
necessary ones should be included in the installation folder. However, if you receive a
message when trying to start the application about a dll file that is missing, please let
me know and | will fix the omission.

Q: Why does my calibrated curve not appear when | press Calibrate?
A: Make sure the Show calibrated spectrum checkbox is checked. See The Graph
Area.

The configuration file

EasySpec.ini is the configuration file that lives in the same folder as the program
file. It is a standard Windows .ini file with [SECTIONS] in square brackets and individual
NAME=VALUE settings in each section. Comments lines begin with a semicolon
symbol.

[GENERAL]

; The last used choices for your equipment are saved here
defaultOptics=Evo 8 + 0.63FR

defaultCamera=178MM

defaultScope=SA-100

; the last calculated dispersion is saved here
dispersion=3.65

; this is a scale factor used to make the IR curve viewable on

; the graphs. This means that a IR curve value of 1.0 is graphed
; as 1000 on the intensity scale

IRCurveScaleFactor=1000

; your name as configured in the Preferences
yourName=David Scott

; the web page used by Help > Online Reference
ReferenceURL=https://en.wikipedia.org/wiki/Stellar classification

; professionally recorded spectra capture data over a much wider
; wavelength range and the spectra for O and B stars can have

; a much higher intensity in UV wavelengths which are typically
; below what an amateur setup can measure. This setting allows

; us to clip of parts of the spectrum below this value.
referenceSpectrumLowerCutoff=3500
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; The data window size used when smoothing curves.
smoothingWindowSize=10

; the data window size used when flattening curves.
flatteningWindowSize=50

[DISPLAY]

; the various colors are save here. The format is:
; r g b alpha

; the alpha value is currently ignored
marginColor=255 255 255 255
graphBackgroundColor=229 229 229 255

axisColor=50 50 50 255

rawSpectrumColor=128 0 64 255
calibratedSpectrumColor=0 0 255 255
referenceSpectrumColor=255 128 0 255
referencelineColor=255 128 0 255
instrumentResponseColor=100 100 100 255
textColor=0 0 0 255

correctedSpectrumColor=0 200 0 255

; the line width - currently only used for the RAW spectrum
spectrumLineWidth=1

The Wavelengths.xml file

This file determines what reference lines and groups are displayed in the The
Reference Area. It is stored in the Resources folder inside the main installation folder.
It is a standard xml file and it can be edited as needed but please only use Notepad as
other editors can over-complicate the file and make it unusable. The format is as
follows:

<wavelengths>

<group name="Hydrogen balmer">
<wavelength name="H alpha" value="6563" calibrate="yes"/>
<wavelength name="H beta" value="4861" calibrate="yes"/>
</group>

<group name="Type O (early)">
<wavelength name="He I" value="4471" />
<wavelength name="He II" value="4686" />
<wavelength name="He II" value="5411" />
</group>

<group name="Type G">
<wavelength name="H" value="3968" />
<wavelength name="K" value="3934" />
<wavelength name="Ca I" value="4227"/>
<wavelength name="G band" value="4300" to="4313" />
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</group>
</wavelengths>

You can have any number of <group> tags and each <group> can have one or more
<wavelengths> inside it. The values are in Angstroms. The calibrate="yes”
attribute specifies that this entry should also be used in the wavelength lists in The
Calibration Area.

Most <wavelength> entries have a name and a value for the wavelength. You can
also define a band of wavelengths as in the “G band” entry above. In these cases, you
provide a value and a second wavelength with the “to” tag.

Version history

Version 1.0
Initial release

Version 1.1

1. Bug fix - The colors would sometimes make the graph lines partially transparent.
2. Bug fix - Reference spectrum F2iv was incorrectly labeled as FO2iv.

3. Bug fix - The spectral type edit control was ignored so the user couldn't manually
enter a spectral class.

Version 1.2

1. Updated wavelengths.xml to include carbon stars.

2. Can now display reference bands, not just lines.

3. Updated Wavelengths.xml to display the G band as a band and added the Telluric
absorption bands.

Version 1.3

1. Updated wavelengths.xml to include Fe Il class novas, S-class stars, more WR
emissions and SN Type la.

2. Reference lines can now be identified with vertical lines or arrow symbols.

3. Added the Notes field.

4. Can now load an external .dat file as a reference curve.

5. Subtract background noise was not subtracting the correct value.

6. Bug fix - calibration failed if the first calibration point was not the zero order peak.

Version 1.4

1. Added the Stellar Properties Calculator

2. Bug fix - The tool tip for Dispersion was attached to the first pixel entry field.
3. Added the ability to do non-linear calibration

Version 1.5
1. Added the ability to define user-defined reference lines.

Version 1.6
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1. Any wavelength value can be entered now when doing a non-linear calibration.
Before, the user had to pick from a list of predefined wavelengths.
2. The spectral types list was not sorted properly.

Version 1.7

1. Changes to the Smoothing preference are automatically reflected in the display
graph.

2. The App would crash if a user-defined wavelength label was too long or if it contained
a double quote character.

3. Fixed incorrect log file message about not being able to open the Wavelngths.xml file.

Version 1.8

1. Added support for loading SER video files.
2. Added support for 16-bit monochrome FITS files
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